提供: Japanese Scratch-Wiki

エディターから転送)

分岐.png:この項目はScratch 3.0のUIを説明しています。過去のバージョンについては、Scratchユーザーインターフェース (2.0)をご覧ください。


Scratch ユーザーインターフェース(UI)はスクラッチャーたちがプログラミングを行う画面のことである。

Scratch 3.0のUI (エディター)

Scratchチームはプログラミング初心者でも簡単にプログラムが作れることを目標にユーザーインターフェースを作っている。

構成

ナビゲーションバー

分岐.png:この項目はエディターで表示されるメニューを説明しています。そのほかの部分については、ナビゲーションバーをご覧ください。


一番最上部にあり、プロジェクトのタイトルやプロジェクトページへの切り替えボタンなどがある。

ファイルメニュー

  • 新規
新しいプロジェクトを作成する。
  • 直ちに保存
プロジェクトをすぐに保存する。
  • コピーを保存
プロジェクトのコピーを保存する。
  • コンピューターから読み込む
コンピューターのプロジェクトファイルを読み込む。
  • コンピューターに保存
コンピューターにプロジェクトファイルを保存する。

編集メニュー

編集メニュー
  • 削除の取り消し
ブロックやスプライトなどの削除を取り消す。
  • ターボモードにする・ターボモードを解除する
ターボモードを切り替える。

チュートリアル

初心者向けのプログラム作成の手順の詳細などを見ることができる。

プロジェクト名

右が共有ボタン。中央がプロジェクト名。右がプロジェクトページへのリンク。

プロジェクトの名前を設定する。

共有ボタン

プロジェクトを共有するボタン。

ステージペイン

上がステージペイン、下がスプライトペイン

ステージと、緑の旗停止ボタン全画面表示の切り替えボタン、ステージの大きさを切り替えるボタンから構成される。

スプライトペイン

スプライトを選ぶボタン

スプライトと背景が一覧表示されている部分と、スプライトのパラメーターを調節する部分、スプライト、背景を追加する部分に分かれている。

スプライト名、表示・非表示切り替え、大きさ、向き、位置の調節ができる。

バックパック

左下半分に、バックパックのエリアがある。

コードタブ

「コード」、「コスチューム(背景)」、「音」のタブを選択できる

画面左上の「コード」を押すとプログラミングができる画面になる。 画面は様々な部分から構成される。

ブロックパレット

左がカテゴリリスト、右がブロックパレット

一番左にある、ブロックを選択する部分。ここからブロックを引っ張り出すことができる。 また、ここにブロックやスクリプトをドロップすると削除することができる。

スクリプトエリア

画面中央部に表示される。 スクリプトブロックを置く場所。

ペイントエディタ

コスチュームや背景に関する管理を行う。

コスチュームペイン

追加ボタン

コスチューム(背景)が一覧と、コスチュームの追加ボタンがある。

一覧の中の一つを選択することで削除や編集をすることができる。

閲覧エリア

ペイントエディター

画面中央部に表示される。

ツール

詳細は「ペイントエディター」を参照

閲覧エリアの周りにあり、画像を編集するためのツールがある。 コスチュームペインで選択された画像を編集・閲覧できる。

音タブ

音ペイン

画面左端にある。 音の一覧と、音の追加ボタンが表示される。

閲覧エリア

中央部にあり、音の波形を見ることができる。

ツール

詳細は「サウンドエディタ」を参照

閲覧エリアの周りにあり、音を編集するためのツールがある。

Cookieは私達のサービスを提供するのに役立ちます。このサービスを使用することにより、お客様はCookieの使用に同意するものとします。